Flash Player 10 en Ubuntu 8.04

Fácil y sencillo.

Primero descargarlo de aquí, todavía es la versión RC1, posterior a la beta, bajar el archivo .tar.gz y descomprimirlo, adentro se encuentra el archivo "libflashplayer.so"

Dejarlo en el escritorio y ejecutar en una consola en un simple copy & paste:

sudo apt-get purge flashplugin-nonfree && sudo mkdir /usr/lib/flashplugin-nonfree && sudo cp -f ~/Desktop/libflashplayer.so /usr/lib/flashplugin-nonfree/ && sudo ln -sf /usr/lib/flashplugin-nonfree/libflashplayer.so /etc/alternatives/firefox-flashplugin && sudo ln -sf /etc/alternatives/firefox-flashplugin /usr/lib/firefox-addons/plugins/flashplayer-alternative.so

Donde dice ~/Desktop fíjense si tienen en español el escritorio, en tal caso iría "Escritorio" en ese lugar.

Lo ejecutan, ingresan su password, reinician Firefox y tendrán funcionando el Flash Player 10 ¿y saben qué? ya no será necesario hacer cosas raras para que las webcams funcionen en sistemas como Ustream.tv o Mogulus, ya las reconoce perfectamente

Y otro detalle importantísimo, ya no se cuelga el Firefox, culpa del Flash Player 9! un gran alivio ya que a veces hasta entrar a este blog se me complicaba si había videos de youtube o las publicidades en el menú, la guía original aquí

Categoría: GNU/Linux Etiquetas:  
Otros posts que podrían llegar a gustarte...

Comentarios

  • John Doe    

    Te falta la parte en la que se baja el libflashplayer.so

    • Responder
    • Citar
    • Comentado:
  • John Doe    

    Oops! No dije nada, pensé que iba a estar todo en el mismo script (lo cual sería más facil).

    • Responder
    • Citar
    • Comentado:
  • Siempre se llama Desktop, sea que este en español o ingles el sistema. Guiño

    • Responder
    • Citar
    • Comentado:
  • Guty    

    Lo mejor de todo es el tema del V4L2, por fín!!

    • Responder
    • Citar
    • Comentado:
  • Fabio    


    Carlos Miranda (Mstaaravin) dijo:

    Siempre se llama Desktop, sea que este en español o ingles el sistema. Guiño


    no si venís de un 7.10 pasado a 8.04, en alguna parte del proceso me cambió el escritorio de Desktop a Escritorio, pensá que yo pasé de Ubuntu 7.10 a Kubuntu 7.10 a Kubuntu 8.04 sin reinstalar el sistema :D solo upgrades :P y si, se me truló el escritorio mal.

    • Responder
    • Citar
    • Comentado:
  • Fabio    


    Guty dijo:

    Lo mejor de todo es el tema del V4L2, por fín!!


    eso y que no se cuelgue a cada rato está genial

    • Responder
    • Citar
    • Comentado:
  • Lukitas    

    en ubuntu 8.04 se llama escritorio, y si arriba le instalas xfce, fluxbox o lo que fuese no te lo toma como escritorio

    • Responder
    • Citar
    • Comentado:
  • Leandro    

    El mejor regalo del dia del niño :D
    Ahora se puede navegar sin que se coma la cpu.
    Grande Fabio, siempre a la vanguardia

    • Responder
    • Citar
    • Comentado:
  • Leandro    

    Me olvidaba sino te molesta, pego un script para usuarios debian.
    Puedo?

    • Responder
    • Citar
    • Comentado:
  •  Neo    


    Leandro dijo:

    Me olvidaba sino te molesta, pego un script para usuarios debian.
    Puedo?


    y los de suse? :|

    • Responder
    • Citar
    • Comentado:
  • Nick    

    ¿Alguien sabe si soluciona el bug que hace que los flash queden como cuadraditos grises? estoy lidiando con eso hace rato, aunque ahora hace mucho que no me pasa, en el issue tracker de ubuntu recomiendan hacer un downgrade a la versión 9.15 (o similar) es lo único que me falta probar.

    • Responder
    • Citar
    • Comentado:
  • Alex    

    Estaba bueno tener el 10 pero NO funciona en 64 bits (Ubuntu 8.04 64 en un AMD Dual Core), así que me lancé a instalarlo y tuve que reinstalar el 9 non-free de vuelta.

    • Responder
    • Citar
    • Comentado:
  • Fabio    


    Alex dijo:

    Estaba bueno tener el 10 pero NO funciona en 64 bits (Ubuntu 8.04 64 en un AMD Dual Core), así que me lancé a instalarlo y tuve que reinstalar el 9 non-free de vuelta.


    En el <a href="http://ubuntuforums.org/showthread.php?t=766683">link que puse</a> si está para 64 bits, las instrucciones son diferentes:


    sudo apt-get purge flashplugin-nonfree && sudo mkdir /usr/lib/flashplugin-nonfree && sudo cp -f ~/Desktop/libflashplayer.so /usr/lib/flashplugin-nonfree/ && sudo nspluginwrapper -i /usr/lib/flashplugin-nonfree/libflashplayer.so && sudo ln -sf /usr/lib/nspluginwrapper/plugins/npwrapper.libflashplayer.so /etc/alternatives/firefox-flashplugin && sudo ln -sf /etc/alternatives/firefox-flashplugin /usr/lib/firefox-addons/plugins/flashplayer-alternative.so && sudo rm -f /usr/lib/firefox/plugins/npwrapper.libflashplayer.so

    • Responder
    • Citar
    • Comentado:
  • minotauro    

    no me salio


    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias
    Leyendo la información de estado... Hecho
    El paquete flashplugin-nonfree no esta instalado, no se eliminará
    0 actualizados, 0 se instalarán, 0 para eliminar y 5 no actualizados.
    mkdir: no se puede crear el directorio «/usr/lib/flashplugin-nonfree»: El fichero ya existe

    • Responder
    • Citar
    • Comentado:
  • Fabio    


    minotauro dijo:

    no me salio


    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias
    Leyendo la información de estado... Hecho
    El paquete flashplugin-nonfree no esta instalado, no se eliminará
    0 actualizados, 0 se instalarán, 0 para eliminar y 5 no actualizados.
    mkdir: no se puede crear el directorio «/usr/lib/flashplugin-nonfree»: El fichero ya existe


    je, es que nunca tuviste el flashplayer instalado

    leé las instrucciones completas del link que puse y listo.

    • Responder
    • Citar
    • Comentado:
  • Alex    

    No hay caso, cambié las instrucciones a 64 bits pero me sale error del pluginwrapper, despues de purgar el flash 9, aun cuando nspluginwrapper está instalado :s

    *** NSPlugin Viewer *** ERROR: libcurl.so.3: cannot open shared object file: No such file or directory
    nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-nonfree/libflashplayer.so


    • Responder
    • Citar
    • Comentado:
  • Jose Luis    

    Fabio tenès idea si esta nueva versiòn "corrige" el incoveniente que tiene cuando ves un video en youtube y querès "agrandar" la imagen con aceleraciòn gràfica se cierra o cuelga? si lo corrige ya me lo instalo :D

    • Responder
    • Citar
    • Comentado:
  • Gez    

    Qué loco. A mi el que se instala en Ubuntu Hardy me va perfecto. Jamás se me cuelga ni nada.
    Igual cuando salga la versión final para 64 bits lo voy a actualizar, claro.

    • Responder
    • Citar
    • Comentado:
  • Alex    

    @ Gez
    Tenés razon, a mi tampoco me da problemas, pero me quise poner el 10 para tener el nuevo. Cuando exista el de 64 bits lo cambiaremos.

    • Responder
    • Citar
    • Comentado:
  • Andrew    

    Realmente me ayudo este post,( tengo una notebook toshiba a215- sp4057 amd x2 64/2gb ram bla bla...)

    Tengo instalado hardy 64, y siempre tuve proplemas para cargar paginas como youtube.com o fabio.com.ar. Recien despues de aplicar las lines de comando de los link que posteo fabio se soluciono mi problema... pero aun persiste por que no puedo cargar youtube simplemente no entra.

    Saludos

    • Responder
    • Citar
    • Comentado:
  • Gracias. Voy a probar.

    Saludos.

    • Responder
    • Citar
    • Comentado:
  • Fabio    


    pablo andres dijo:

    Gracias. Voy a probar.

    Saludos.


    pablo, ya salió la nueva versión del flash player y tiene un .deb para instalarlo directamente, andá a la web de adobe que lo instala fácil

    • Responder
    • Citar
    • Comentado:
  • jsn301    

    hola, yo lo he intentado y me da esto:
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias
    Leyendo la información de estado... Hecho
    El paquete flashplugin-nonfree no esta instalado, no se eliminará
    0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.
    mkdir: no se puede crear el directorio «/usr/lib/flashplugin-nonfree»: El fichero ya existe

    ¿ké tengo ke hacer? o

    • Responder
    • Citar
    • Comentado:
  • Fabio    


    jsn301 dijo:

    hola, yo lo he intentado y me da esto:
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias
    Leyendo la información de estado... Hecho
    El paquete flashplugin-nonfree no esta instalado, no se eliminará
    0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.
    mkdir: no se puede crear el directorio «/usr/lib/flashplugin-nonfree»: El fichero ya existe

    ¿ké tengo ke hacer? o


    dependiendo la versión de ubuntu que tengas, lo primero que tenés uqe hacer es:

    sudo apt-get install flashplugin-nonfree

    así te lo instala. El artículo está escrito para actualizarlo si no tenés el 10, si con esto ya te instala el 10, listo, no hagas más.

    • Responder
    • Citar
    • Comentado:
  • Gez-    

    En Adobe Labs hay una versión preliminar nativa de 64 bits que zafa del wrapper. Anda perrrrfecto en intrepid.

    • Responder
    • Citar
    • Comentado:
  • Xozè    

    Muchas gracias por tu aporte, hacía mucho tiempo trataba de solucionar varios problemas con Flash, y con este blog se solucionaron todos. Gracias hombre.

    • Responder
    • Citar
    • Comentado:
  • Melvin    

    hola soy nuevo en ubunto y tengo este proglema lo intente pero me sale q no pudo desbloquera var/lib algo asi q puedo hacer

    • Responder
    • Citar
    • Comentado:

Deje su comentario:

Tranquilo, su email nunca será revelado.
La gente de bien tiene URL, no se olvide del http/https
Para evitar bots, si se tardó mucho en leer la nota seguramente no sirva y tenga que intentar dos veces

Negrita Cursiva Imagen Enlace


comentarios ofensivos o que no hagan al enriquecimiento del post serán borrados/editados por el administrador